Just verifying....

View previous topic View next topic Go down

Just verifying....

Post by rkraposa on Thu May 26, 2011 11:55 pm

Out of the blue...and I mean seriously quick..I walked by my tank and it smelled bad. Caught me by surprise because I am way over-filtered with CRYSTAL clear water. I have a 36 Gallon (for those who may not remember me) and because I am a clean freak, I normally take out about 5 gallons a week and vacuum in sections. And then usually about once a month I'll take out about 10 (instead of 5) and vacuum a bit deeper. I say that because I just cleaned the tank on Saturday and there was NO smell whatsoever. Anyway, I was scheduled to replace my Chemipure this coming Saturday and I wondered if this could be the problem. When I pulled it out...it smelled terrible. So, as I already had the new one on hand, I replaced it. As I said, verifying....this was the problem, right??

Thanks
avatar
rkraposa

Posts : 39
Join date : 2011-01-08
Age : 46
Location : Pittsburgh, PA

View user profile

Back to top Go down

Re: Just verifying....

Post by Norm66 on Fri May 27, 2011 6:57 am

I don't know anything about Chemicure, but usually when a tank starts to smell bad it's because there's a carcass decaying somewhere. Are all of your fish accounted for?

Norm66

Posts : 204
Join date : 2011-04-13
Age : 45
Location : Parkersburg, WV

View user profile http://Maliceband.com

Back to top Go down

Re: Just verifying....

Post by rkraposa on Fri May 27, 2011 8:46 am

Yep, all there
avatar
rkraposa

Posts : 39
Join date : 2011-01-08
Age : 46
Location : Pittsburgh, PA

View user profile

Back to top Go down

Re: Just verifying....

Post by Aura on Fri May 27, 2011 9:35 am

I don't use Chemipure either. Did replacing it fix the problem?

I can't remember how heavily your tank is stocked, but if there are a lot of fish in there, you could increase the amount of water removed at water changes. I'm sure this is overkill, but I do at least 50% every week on mine. (Not saying that's the cause of your smell problem!)
avatar
Aura
Admin

Posts : 2580
Join date : 2009-08-14
Location : WA

View user profile

Back to top Go down

Re: Just verifying....

Post by rkraposa on Fri May 27, 2011 9:55 am

It seemed to fix the problem. I mentioned the chemipure by name just out of habit. Ultimately, my question was...if the carbon is not changed at the proper time...could it be the cause of the smell? For those who don't use chemipure and use HOB filters such as Aquaclear.....I highly recommend checking it out. You change them less frequently, it has some sort of nutrients/resins to help with the health of your fish and your tank...and your tank will be crystal clear. I run 2 Aquaclear 70's on my tank. One has a regular chemipure and the other has a chemipure elite. They are more expensive up front, but more cost efficient overall because of how long they last. They say anywhere from 3-6 months. I seem to get about 4 months, and I assume it will be based on how heavily your tank is stocked.
avatar
rkraposa

Posts : 39
Join date : 2011-01-08
Age : 46
Location : Pittsburgh, PA

View user profile

Back to top Go down

Re: Just verifying....

Post by Aura on Fri May 27, 2011 10:17 am

I have three jars of it sitting on the shelf of one of my tank stands. I don't remember when or why I bought them, but they have been there for a long, long time. Embarassed I might have to give them a try one of these days. I wonder if they expire?

I don't use carbon either. With running two filters on each tank and the large weekly water changes I haven't had any problems with water clarity or unusual odors.
avatar
Aura
Admin

Posts : 2580
Join date : 2009-08-14
Location : WA

View user profile

Back to top Go down

Re: Just verifying....

Post by rkraposa on Fri May 27, 2011 10:31 am

Ha....you must have bought them for some reason. While I have no issues doing maintenance on my tanks, I prefer not to do huge water changes if I can help it. Of course, I think you have been at this longer than I, so I certainly don't question your ways! Smile I have a fantastic LFS and they recommended it and I've been very happy with the product. Like I said, I will do around 5 gallons, about 15%, most of the time 2 weeks in a row, then the 3rd I will do about 10 or so. I really think the Chem keeps it well maintained. Really stabilizes the PH, too.
avatar
rkraposa

Posts : 39
Join date : 2011-01-08
Age : 46
Location : Pittsburgh, PA

View user profile

Back to top Go down

Re: Just verifying....

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum